Your requirements could not be resolved to an installable set of packages.
- Root composer.json requires fof/upload 0.10.0 -> satisfiable by fof/upload[0.10.0].
- fof/upload 0.10.0 requires flarum/core >=0.1.0-beta.12 <0.1.0-beta.14 -> found flarum/core[v0.1.0-beta.12, v0.1.0-beta.13] but the package is fixed to v0.1.0-beta.14.1 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
Use the option –with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
Installation failed, reverting ./composer.json and ./composer.lock to their original content.